coil pack not firring 4g93t

New member introductions. Introduce yourself!
Post Reply
pez1970
Newbville
Posts: 3
Joined: Sun Feb 18, 2018 9:59 am

coil pack not firring 4g93t

Post by pez1970 » Sun Feb 18, 2018 10:09 am

hi newbe here from uk
looking for wirring info on a 4g63/93 lancer gsr 1992
i bought a proton pickup with this conversion in but the last owner wirred a direct feed swith to the back of the fuel relay.
this switch was left on over a weekend and flattened the battery.charged battery back up from flat to find it was only firring on 1 and 4.have changed cam pickup,leads,transistor,plugs,ecu,swapped coils round but still the same.im at wits end.PLEASE PLEASE PLEASE can someone help
thanx in advance :oops: :evil: :?: :(

User avatar
4g63mightymax
Site Admin
Posts: 7991
Joined: Sat Mar 18, 2006 7:40 am
Location: MA
Contact:

Re: coil pack not firring 4g93t

Post by 4g63mightymax » Sun Feb 18, 2018 2:06 pm

Was it running fine before the dead battery?
Jeremy N.
1964 Impala Convertible
1972 Pontiac Lemans
2016 Subaru Impreza

pez1970
Newbville
Posts: 3
Joined: Sun Feb 18, 2018 9:59 am

Re: coil pack not firring 4g93t

Post by pez1970 » Sun Feb 18, 2018 2:26 pm

hi
yes it was running fine until the switch was left on that someone had wirred in to fuel relay and flattened battery.charged battery back up and was only running on 1&4

User avatar
4g63mightymax
Site Admin
Posts: 7991
Joined: Sat Mar 18, 2006 7:40 am
Location: MA
Contact:

Re: coil pack not firring 4g93t

Post by 4g63mightymax » Mon Feb 19, 2018 12:03 pm

Are you sure that you are missing spark on those two cylinders and not fuel? Or are you missing spark AND fuel on 2&3 ?
Jeremy N.
1964 Impala Convertible
1972 Pontiac Lemans
2016 Subaru Impreza

pez1970
Newbville
Posts: 3
Joined: Sun Feb 18, 2018 9:59 am

Re: coil pack not firring 4g93t

Post by pez1970 » Mon Feb 19, 2018 4:49 pm

i cant see a spark off the coil pack but today i have bought a new fuel pump as have also been told by another local mechanic that low fuel pressure can also make it look like no spark.i checked fuel today before ordering pump and found there is only constant fuel when cranking.i thought there was ment to be a small serge before cranking and constant after cranking.this is why i have decided to try a new fuel pump.i may be wrong but its worth a try dont know what else to try :roll: :oops:

User avatar
4g63mightymax
Site Admin
Posts: 7991
Joined: Sat Mar 18, 2006 7:40 am
Location: MA
Contact:

Re: coil pack not firring 4g93t

Post by 4g63mightymax » Tue Feb 20, 2018 9:08 am

The fuel pump should only run when you are trying to start the engine, and then continues when the engine actually starts. The fuel pump doesn't have the "priming" that most cars do for 2-3 seconds when you turn the key to the run position. What you are describing is 100% normal. You probably don't need a fuel pump.

If I were you, I would go back to basics:
- Test for spark at every cylinder. Stick a spare spark plug in the end of each spark plug wire, ground the spark plug, and see if it sparks when you spin the engine.
- Test the injectors with noid lights. They are cheap for a set of them, and they will tell you if your injectors are getting the signal to spark or not. (http://www.jegs.com/i/JEGS-Performance- ... 0/10002/-1)
- Check for compression. Get the compression tester for $15 at your local auto part store, or online, and make sure that all cylinders have ~155psi of compression.

One of those 3 tests will give you the direction that you want to go in.
Jeremy N.
1964 Impala Convertible
1972 Pontiac Lemans
2016 Subaru Impreza

Post Reply